If you have problems getting your Elektron device connected to Overbridge Engine, there are several ways to solve this depending on what kind of connection problem you have.

MY ELEKTRON DEVICE IS NOT VISIBLE IN OVERBRIDGE ENGINE

Your Elektron device is not visible/not detected in the Overbridge Engine application.

  1. Download and install the latest version of Overbridge and device OS. For more information, please see this article about how to install Overbridge.

  2. Set your Elektron device to Overbridge mode. For more information, please see the User Manual for your Elektron device.

  3. Make sure the USB cable is connected correctly.

If you are using a Mac, please read this article before continuing any further troubleshooting.

MY ELEKTRON DEVICE IS VISIBLE IN OVERBRIDGE ENGINE BUT IS NOT CONNECTING

Overbridge uses local ports to communicate between different applications within the Overbridge suite, and between Overbridge and the computer. But other applications installed on your system may already use the same ports that Overbridge needs for communication. For Overbridge to work, you must close the other applications that use these ports.

Port 46000 needs to be free for Overbridge Engine to be able to communicate with your computer. Also, each Elektron device that you use in Overbridge must be able to use port 460n0, 460n1, and 460n2, where n is the device that you have added.

Example:
If you have two Elektron devices connected, you need to make sure that the following ports are free:

46000 (for Overbridge Engine - Computer communication)
46010, 46011, 46012 (for Elektron device 1 - Overbridge Engine communication)
46020, 46021, 46022 (for Elektron device 2 - Overbridge Engine communication)

Please see this article for information about how to find what ports are in use by the computer's processes and applications, and how to free them up.

MY ELEKTRON DEVICE IS VISIBLE IN OVERBRIDGE ENGINE BUT SHOWS AN ERROR

Your Elektron device is shown as “Measuring” or “Fault” in Overbridge Engine when you try to connect them to Overbridge and it never gets out of this state.

  1. Make sure you update to the latest OS for your Elektron device. Available for download here.

  2. Configure the devices’ audio channels to send to and from the device in the Overbridge Control Panel. (Only applicable for Analog Rytm MK I, Analog Four MK I, Analog Heat MK I, and Analog Keys.)

  3. Another cause of this problem might be because of USB2/USB3 and chipset issues. Please see this article concerning USB2/USB3 and chipset issues and how to solve them.